Slow printing and reports of no printing

Incident Report for Jungle Commerce

Resolved

The issue was caused by interruptions in Jungle's underlying printer network. It has now been resolved.

Jungle is adding more checks and redundancy, to prevent similar problems in future.
Posted May 26, 2025 - 11:38 AEST

Investigating

We are currently investigating the issue.
Posted May 26, 2025 - 10:43 AEST
This incident affected: Printing and Devices.